POJ 2833 The Average 优先队列

The Average (POJ 2833)
Time Limit: 6000MS Memory Limit: 10000K
Case Time Limit: 4000MS

Description

In a speech contest, when a contestant finishes his speech, the judges will then grade his performance. The staff remove the highest grade and the lowest grade and compute the average of the rest as the contestant’s final grade. This is an easy problem because usually there are only several judges.

Let’s consider a generalized form of the problem above. Given n positive integers, remove the greatest n1 ones and the least n2 ones, and compute the average of the rest.

Input

The input consists of several test cases. Each test case consists two lines. The first line contains three integers n1, n2 and n (1 ≤ n1, n2 ≤ 10, n1 + n2 < n ≤ 5,000,000) separate by a single space. The second line contains n positive integers ai (1 ≤ ai ≤ 108 for all i s.t. 1 ≤ i ≤ n) separated by a single space. The last test case is followed by three zeroes.

Output

For each test case, output the average rounded to six digits after decimal point in a separate line.

Sample Input

1 2 5
1 2 3 4 5
4 2 10
2121187 902 485 531 843 582 652 926 220 155
0 0 0
Sample Output

3.500000
562.500000
Hint

This problem has very large input data. scanf and printf are recommended for C++ I/O.

The memory limit might not allow you to store everything in the memory.

解题思路:使用最小优先队列qmin与最大优先队列qmax维护最小值与最大值

C++代码如下:


#include <cstdio>
#include <queue>
#include <vector>
using namespace std;
priority_queue <int,vector<int>, less<int> > qmax;
priority_queue <int,vector<int>, greater<int> > qmin;
int main()
{
    int num,i,minus;
    long long sum;
    int n,m,k;
    int minsize,maxsize;
    while (scanf("%d%d%d",&m,&n,&k),m || n || k)
    {
        minsize = maxsize = 0;
        sum = 0;
        for (i = 0; i < k; i ++)
        {
            scanf("%d",&num);
            sum += (long long)num;
            if (minsize < m)
            {
                qmin.push(num);
                minsize ++;
            }
            else
            {
                if (num > qmin.top())
                {
                    qmin.pop();
                    qmin.push(num);
                }
            }
            if (maxsize < n)
            {
                qmax.push(num);
                maxsize ++;
            }
            else
            {
                if (num < qmax.top())
                {
                    qmax.pop();
                    qmax.push(num);
                }
            }
        }
        minus = 0;
        while (!qmax.empty())
        {
            minus += qmax.top();
            qmax.pop();
        }
        while (!qmin.empty())
        {
            minus += qmin.top();
            qmin.pop();
        }
        printf("%f\n",(1.0 * sum - (long long)minus) / (1.0 * (k - m - n)));
    }
    return 0;
}

本文链接:http://bookshadow.com/weblog/2014/05/03/poj-2833-average/
请尊重作者的劳动成果,转载请注明出处!书影博客保留对文章的所有权利。

如果您喜欢这篇博文,欢迎您捐赠书影博客: ,查看支付宝二维码

Pingbacks已关闭。

暂无评论

张贴您的评论