Windows 8.1搭建PHP5.6与Apache 2.4开发环境故障解决

配合使用Apache 2.4.10 Win32(Apache Lounge构建版本)以及PHP 5.6.3 VC11 x86 Thread Safe(VC11 x86 线程安全版本),可以在Windows 8.1操作系统中搭建PHP Web开发环境。

在Windows 8.1操作系统中搭建PHP + Apache Web开发环境时,需要注意如下问题。

1. Apache使用mod_php方式以模块形式集成PHP时,需要使用Thread Safe(线程安全)版本,不要选择Non Thread Safe(非线程安全版本)。

使用mod_php方式需要在httpd.conf配置文件中添加如下代码:

PHPIniDir "C:/php"
LoadModule php5_module "c:/php/php5apache2_4.dll"
AddHandler application/x-httpd-php .php

而php5_module模块php5apache2_4.dll(php5apache2_x.dll)只在Thread Safe版本中有提供。

在运行Apache24/bin目录下运行httpd.exe -t时,如果出现如下错误提示信息:

httpd.exe: Syntax error on line 531 of C:/Apache24/conf/httpd.conf: Cannot load c:/php56/php5apache2_4.dll into server: \xd5\xd2\xb2\xbb\xb5\xbd\xd6\xb8\xb6\xa8\xb5\xc4\xc4\xa3\xbf\xe9\xa1\xa3

是由于php5apache2_4.dll动态链接库文件的版本与当前的php版本或Apache版本不匹配。

笔者在安装过程中遇到了上述错误,起初在Non Thread Safe中没有找到php5apache2_4.dll,尝试从链接https://www.apachelounge.com/download/additional/中自行下载php5apache2_4.dll-php-5.4-win32.zip并解压至php目录下,而php5apache2_4.dll与已安装的php版本和Apache版本不匹配。

另请参阅:http://www.apachelounge.com/viewtopic.php?t=5451

2. Apache Windows编译版可以从http://www.apachelounge.com/download/下载,不建议从官网下载源文件自行编译。

3. Apache所在目录与httpd.conf配置文件中ServerRoot指定的位置不一致时,会出现如下错误:

httpd.exe: Syntax error on line 72 of C:/Apache24/conf/httpd.conf: Cannot load modules/mod_access_compat.so into server: \xd5\xd2\xb2\xbb\xb5\xbd\xd6\xb8\xb6\xa8\xb5\xc4\xc4\xa3\xbf\xe9\xa1\xa3

需要确保Apache所在目录与http.conf中指定的ServerRoot一致。

本文链接:http://bookshadow.com/weblog/2014/11/27/windows-81-php-56-apache-24-trouble-shooting/
请尊重作者的劳动成果,转载请注明出处!书影博客保留对文章的所有权利。

如果您喜欢这篇博文,欢迎您捐赠书影博客: ,查看支付宝二维码